fox-cli

1.2.2 • Public • Published

fox-cli

A simple CLI for scaffolding frondend projects.

Installation

Prerequisites: Node.js (>=4.x, 6.x preferred), npm version 3+ and Git.

npm install -g fox-cli

Usage

Generate your project:

fox init

Directory tree:

.
├── config.json
├── gulpfile.babel.js
├── package.json
├── nginx
├── src
└── utils.js

Remove your project:

fox delete yourProject

Install dependencies:

cd yourProject && npm i

Run your project:

npm run dev # or gulp dev 

Build your project:

npm run build # or gulp build 

License

ISC

Keywords

install

npm i fox-cli

Downloadsweekly downloads

1

version

1.2.2

license

ISC

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability