Nostalgic Pizza Manager

    formsy-react-components
    TypeScript icon, indicating that this package has built-in type declarations

    2.0.0-beta.5 • Public • Published

    formsy-react-components

    Build Status npm version GitHub release GitHub contributors

    Note: The work here on the master branch is for upcoming release that supports Bootstrap 4. The source for current (1.x) releases can be found on the release-1.x branch.


    formsy-react-components is a selection of React components that render form elements for use in a formsy-react form.

    The components render markup to be quickly included in a Bootstrap 4 form. This includes a <label>, help text, and some validation styling tied to formsy’s validation state and validation messages.

    Install

    To install using yarn:

    yarn add formsy-react
    yarn add formsy-react-components@next
    

    To install using npm:

    npm install --save formsy-react
    npm install --save formsy-react-components@next
    

    Browser Support

    This should run on browsers where both Bootstrap and React are supported.

    • Internet Explorer: polyfills for Set and Array.from are required.

    Usage

    import { Form, Input } from 'formsy-react-components';
     
    const MyForm = (props) => {
      return (
        <Form onSubmit={(data) => { console.log(data) }}>
          <Input
            name="firstname"
            label="What is your first name?"
          />
        </Form>
      )
    }

    Examples

    Documentation

    Documentation is a work in progress!

    • For a working code example, visit the Playground, then examine the source.
    • There is some information in /docs.

    Install

    npm i formsy-react-components

    DownloadsWeekly Downloads

    2,433

    Version

    2.0.0-beta.5

    License

    MIT

    Unpacked Size

    437 kB

    Total Files

    96

    Last publish

    Collaborators

    • twisty