Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

expo-sms

4.0.0 • Public • Published

expo-sms

Provides access to the system's UI/app for sending SMS messages.

API documentation

Installation

This package is pre-installed in managed Expo projects. You may skip the rest of the installation guide if this applies to you.

For bare React Native projects, you must ensure that you have installed and configured the @unimodules/core package before continuing.

Add the package to your npm dependencies

npm install expo-sms

Configure for iOS

Add the dependency to your Podfile and then run pod install.

pod 'EXSMS', path: '../node_modules/expo-sms/ios'

Configure for Android

  1. Append the following lines to android/settings.gradle:
include ':expo-sms'
project(':expo-sms').projectDir = new File(rootProject.projectDir, '../node_modules/expo-sms/android')
  1. Insert the following lines inside the dependencies block in android/app/build.gradle:
api project(':expo-sms')
  1. In MainApplication.java, import the package and add it to the ReactModuleRegistryProvider list:
import expo.modules.sms.SMSPackage;
private final ReactModuleRegistryProvider mModuleRegistryProvider = new ReactModuleRegistryProvider(Arrays.<Package>asList(
  // Your other packages will be here 
  new SMSPackage()
)Arrays.<SingletonModule>asList());

Contributing

Contributions are very welcome! Please refer to guidelines described in the contributing guide.

install

npm i expo-sms

Downloadsweekly downloads

45,365

version

4.0.0

license

MIT

homepage

docs.expo.io

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
Report a vulnerability