Nostradamus Prophecy Machine
Learn how companies like Phone2Action are using npm in their front-end developmentJoin the conversation »

This package has been deprecated

Author message:

This package has been deprecated, please use @wordpress/eslint-plugin or @wordpress/scripts

eslint-plugin-wordpress

0.1.0 • Public • Published

eslint-plugin-wordpress

A collection of custom ESLint rules that help enforce JavaScript coding standard in the WordPress project.

Installation

You'll first need to install ESLint:

$ npm i eslint --save-dev

Next, install eslint-plugin-wordpress:

$ npm install eslint-plugin-wordpress --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install eslint-plugin-wordpress globally.

Usage

Add wordpress to the plugins section of your .eslintrc.json configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "wordpress"
    ]
}

Or add wordpress to the plugins section of your .eslintrc.js configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "wordpress"
    ]
}

Or add wordpress to the plugins section of your .eslintrc.yaml/.eslintrc.yml configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "wordpress"
    ]
}

http://eslint.org/docs/user-guide/configuring.html#configuration-file-formats

Then configure the rules you want to use under the rules section.

{
    "rules": {
        "wordpress/space-negation-operator": 2
    }
}

Rules

Ressources

Code Sources, References

Install

npm i eslint-plugin-wordpress

DownloadsWeekly Downloads

1,429

Version

0.1.0

License

MIT

Last publish

Collaborators

  • avatar