Get unlimited public & private packages + team-based management with npm Teams.Learn more »

eslint-plugin-superstition

0.3.1 • Public • Published

eslint-plugin-superstition

ESLint superstition rules (forbid using numbers 13, 666 and etc.)

Install

$ npm install --save-dev eslint eslint-plugin-superstition

Usage

Configure it in package.json.

{
  "name": "my-awesome-project",
  "eslintConfig": {
    "env": {
      "es6": true
    },
    "plugins": [
      "superstition"
    ],
    "rules": {
      "superstition/must-have-8": "error",
      "superstition/no-number-13": "error",
      "superstition/no-number-39": "error",
      "superstition/no-number-4": "error",
      "superstition/no-number-666": "error",
      "no-var": "error"
    }
  }
}

Rules

  • must-have-8 - Must have to use of the number 8. It brings good luck.
  • no-number-13 - Forbid the use of number 13. It is a bad omen.
  • no-number-39 - Forbid the use of number 39. It is a bad omen.
  • no-number-4 - Forbid the use of number 4. It is a bad omen.
  • no-number-666 - Forbid the use of number 666. It is a bad omen.

Recommended configuration

This plugin exports a recommended configuration that enforces good practices.

To enable this configuration, use the extends property in your package.json.

{
  "name": "my-awesome-project",
  "eslintConfig": {
    "plugins": [
      "superstition"
    ],
    "extends": "plugin:superstition/recommended"
  }
}

See ESLint documentation for more information about extending configuration files.

Notes

Based on eslint-plugin-fp


MIT © Pavel Gurov

Install

npm i eslint-plugin-superstition

DownloadsWeekly Downloads

6

Version

0.3.1

License

MIT

Unpacked Size

8.29 kB

Total Files

9

Last publish

Collaborators

  • avatar