eslint-plugin-segment-security

0.9.0 • Public • Published

eslint-plugin-segment-security

An eslint plugin that checks for security issues in javascript, node, and react.

Installation

You'll first need to install ESLint:

$ npm i eslint --save-dev

Next, install eslint-plugin-segment-security:

$ npm install eslint-plugin-segment-security --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install eslint-plugin-segment-security globally.

Usage

Add segment-security to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "segment-security"
    ]
}

Then configure the rules you want to use under the rules section.

{
    "rules": {
        "segment-security/rule-name": 2
    }
}

Supported Rules

  • Fill in provided rules here

Install

npm i eslint-plugin-segment-security

DownloadsWeekly Downloads

586

Version

0.9.0

License

ISC

Unpacked Size

8.14 kB

Total Files

6

Last publish

Collaborators

  • dscrobonia