Nixon's Pants Missing

    eslint-plugin-patternfly-react

    4.80.4 • Public • Published

    eslint-plugin-patternfly-react

    This package provides PatternFly React all ESLint rules bundled together for use in PatternFly React and downstream applications.

    Installing

    yarn add -D eslint-plugin-patternfly-react
    

    or

    npm install eslint-plugin-patternfly-react --save-dev
    

    Usage

    Add eslint-plugin-patternfly-react to your .eslintrc.json or .eslintrc.js.

    .eslintrc.json:

    {
      "plugins": ["plugin:patternfly-react/recommended"]
    }

    .eslintrc.js:

    module.exports = {
      root: true,
      extends: ['plugin:patternfly-react/recommended']
    };

    Building

    yarn build
    

    Note the build scripts for this are located in the root package.json under yarn build.

    Publishing

    yarn publish
    

    Install

    npm i eslint-plugin-patternfly-react

    DownloadsWeekly Downloads

    738

    Version

    4.80.4

    License

    MIT

    Unpacked Size

    111 kB

    Total Files

    10

    Last publish

    Collaborators

    • realredallen
    • priley86
    • patternfly-build
    • dgutride