Noodles, Poodles and More!

    eslint-config-ylfe

    0.2.2 • Public • Published

    eslint-config-ylfe

    Eslint rules for ylfe based on Elemefe's eslint rule. Forked form project

    Usage

    eslint-config-ylfe

    Our default export contains all of our ESLint rules, including ECMAScript 6.

    First, install this package

    npm install --save-dev eslint-config-ylfe eslint

    Then add following contents to your .eslintrc file

    {
      "extends": "ylfe"
    }
    

    eslint-config-ylfe/vue

    Vue project common rules

    First, install this package and necessary plugins

    npm install --save-dev eslint-config-ylfe eslint babel-eslint eslint-plugin-vue

    Then add following contents to your .eslintrc file

    {
      "extends": ['plugin:vue/base', 'ylfe/vue']
    }
    

    eslint-config-ylfe/vue

    Wechat mini-porgram common rules

    First, install this package and necessary plugins

    npm install --save-dev eslint-config-ylfe eslint prettier

    Then add following contents to your .eslintrc file

    {
      "extends": ['ylfe/wechat', plugin:prettier/recommended]
    }
    

    eslint 配置

    配置文件参考 .eslintrc.js

    VSCode配置

    vscode配合eslint, 自动fix错误,需要安装Eslint插件

    顺便提一下,最好EditorConfig和Vetur也装一下(具体作用自行搜索)

    vscode配置(settings.json)

    "eslint.validate": [
        "javascript",
        "javascriptreact",
        "html",
        { "language": "vue", "autoFix": true }
      ],
    "eslint.options": {
        "plugins": ["vue"]
    },
    "eslint.autoFixOnSave": true
    

    License

    MIT

    Install

    npm i eslint-config-ylfe

    DownloadsWeekly Downloads

    16

    Version

    0.2.2

    License

    MIT

    Unpacked Size

    11.2 kB

    Total Files

    10

    Last publish

    Collaborators

    • chaslee
    • jiaryoo