eslint-config-lumigu

    1.0.3 • Public • Published

    eslint-config-lumigu

    ESLint configuration for Lumigu ECMAScript projects.

    Install

    Add the eslint-config-lumigu module and its peer dependencies to devDependencies:

    $ npm install eslint-config-lumigu eslint eslint-plugin-import eslint-plugin-node -D

    Usage

    Shareable configurations are meant to be used with the extends feature in .eslintrc files. First, in the root of your project create a new .eslintrc file:

    $ touch .estlingrc

    Second, open your new .eslintrc file in your favorite editor, and the following JSON object:

    {
      "extends": "lumigu"
    }

    You can add your own customization by adding overrides to the rules property.

    Finally, you can validate your ECMAScript project by adding an NPM script to your package.json file:

    {
      "scipts": {
        "lint": "eslint . --config=eslintrc",
      }
    }

    Install

    npm i eslint-config-lumigu

    DownloadsWeekly Downloads

    0

    Version

    1.0.3

    License

    MIT

    Unpacked Size

    97.8 kB

    Total Files

    8

    Last publish

    Collaborators

    • dsfields