dris-workflows

## Requirements

DRIS Workflows

  • Node.js (developed with v0.6.14)
  • MongoDB (developed with v2.0.3)
  • Fedora Commons (developed with v3.5)
  • Expresso (tests)

To install the needed dependancies for this web-application you must do the following, from the root directory of the web-application.

$ npm install

To get data from the backend services you need to configure configuration.js with the correct server path to the api server.

To start the application, run "app.js" in node.

$ node app.js

The application should be running at http://localhost:3000