dri-api

DRI API

  • Node.js (developed with v0.6.14)
  • MongoDB (developed with v2.0.3)
  • Fedora Commons (developed with v3.5)
  • Mocha (tests)

To install the needed dependancies for this web-application you must do the following, from the root directory of the web-application.

$ npm install

Create a config.json from the template provided (config.json.tp)

To start the application, run "app.js" in node.

$ node app.js

The application should be running at http://localhost:4000 The port number can be changed in the app.js file.

  • You can only approve "Items"
  • Deleting an object is not done recursively
  • Operations with MongoDB and Fedora Commons don't use transactions