Wondering what’s next for npm?Check out our public roadmap! »

    collect-v8-coverage
    TypeScript icon, indicating that this package has built-in type declarations

    1.0.1 • Public • Published

    collect-v8-coverage

    Use this module to start and stop the V8 inspector manually and collect precise coverage.

    const {CoverageInstrumenter} = require('collect-v8-coverage');
     
    const instrumenter = new CoverageInstrumenter();
     
    await instrumenter.startInstrumenting();
     
    // require some modules, run some code
     
    const coverage = await instrumenter.stopInstrumenting();

    Keywords

    none

    Install

    npm i collect-v8-coverage

    DownloadsWeekly Downloads

    7,199,881

    Version

    1.0.1

    License

    MIT

    Unpacked Size

    4.14 kB

    Total Files

    6

    Last publish

    Collaborators

    • avatar