code-fabric
TypeScript icon, indicating that this package has built-in type declarations

2.3.0 • Public • Published

code-fabric

A collection of configuration files containing prettier, eslint, stylelint

Install

npm install code-fabric --save-dev
# or
yarn add code-fabric --dev

Usage

in .eslintrc.js

module.exports = {
  extends: [require.resolve('code-fabric/eslint')],
  rules: {},
};

in .prettierrc.js

const prettier = require('code-fabric/prettier');

module.exports = {
  ...prettier,
};

in .stylelintrc.js

module.exports = {
  extends: [require.resolve('code-fabric/stylelint')],
  rules: {},
};

in ESM

import { eslint, prettier, stylelint } from 'code-fabric';
// you can use this config

Package Sidebar

Install

npm i code-fabric

Weekly Downloads

7

Version

2.3.0

License

MIT

Unpacked Size

32.6 kB

Total Files

16

Last publish

Collaborators

  • islizeqiang