Novel Planetary Movement

    bunyan-blip

    1.0.2 • Public • Published

    bunyan-blip

    CircleCI Codacy Badge

    Blip stuff from bunyan

    Installation

    npm i -S bunyan-blip

    Use

    const bunyan     = require('bunyan');
    const BunyanBlip = require('bunyan-blip');
    const BlipClient = require('blip-client');
    
    const blipClient = BlipClient.createClient('mybliphost.com', 8080, 'some service', 'prod');
    
    const logger = bunyan.createLogger({
        name:    'my app',
        streams: {
           type: 'raw',
           stream: new BunyanBlip(blipClient, 'error')
         }
      });
    
    
    logger.info('Not sent to blip server');
    logger.error('Sent to blip server because its above the threshold');

    Keywords

    none

    Install

    npm i bunyan-blip

    DownloadsWeekly Downloads

    4

    Version

    1.0.2

    License

    MIT

    Last publish

    Collaborators