Necessarily Precedes Mischief

    browserify-require-not-found-parent

    0.1.0 • Public • Published

    When resolving a require() fails with MODULE_NOT_FOUND (Error: Cannot find module 'dep' from 'parent'), report the requiring module's pathname instead of just its directory.

    Installation:

    browserify-require-not-found-parent on npm.

    Usage:

    var browserifyRequireNotFoundParent =
      require("browserify-require-not-found-parent");
     
    browserify()
    .plugin(browserifyRequireNotFoundParent)

    See:

    https://github.com/substack/node-resolve/pull/64

    https://github.com/substack/node-browserify/issues/1083

    https://github.com/substack/node-browserify/issues/1117

    Install

    npm i browserify-require-not-found-parent

    DownloadsWeekly Downloads

    129

    Version

    0.1.0

    License

    MIT

    Last publish

    Collaborators

    • jmm