Have ideas to improve npm?Join in the discussion! »

    babel-preset-gatsby

    1.3.0 • Public • Published

    babel-preset-gatsby

    Gatsby uses the phenomenal project Babel to enable support for writing modern JavaScript — while still supporting older browsers. This package contains the default Babel setup for all Gatsby projects.

    For more information on how to customize the Babel configuration of your Gatsby site, check out our documentation.

    Packages

    Usage

    Install babel-preset-gatsby and add a .babelrc file with the following content to the root of your project:

    npm install --dev babel-preset-gatsby
    {
      "presets": ["babel-preset-gatsby"]
    }

    Options

    targets

    { [string]: number | string }, defaults to { "browsers": ["last 4 versions", "safari >= 7", "ie >= 9"] } in production and { "browsers": ["last 2 versions", "not ie <= 11", "not android 4.4.3"] } in development when targeting the browser and { "node": 6 } in production and { "node": "current" } in development when targeting Node.js.

    Use this option to configure custom target browsers.

    Keywords

    none

    Install

    npm i babel-preset-gatsby

    DownloadsWeekly Downloads

    431,135

    Version

    1.3.0

    License

    MIT

    Unpacked Size

    38.3 kB

    Total Files

    9

    Last publish

    Collaborators

    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar