node package manager

babel-preset-es2015-without-strict

babel-preset-es2015-without-strict

Babel preset for all es2015 plugins without 'use strict' prepend.

Install

$ npm install --save-dev babel-preset-es2015-without-strict

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["es2015-without-strict"]
}

Via CLI

$ babel script.js --presets es2015-without-strict 

Via Node API

require("babel-core").transform("code", {
  presets: ["es2015-without-strict"]
});