babel-plugin-transform-typescript

7.0.0-alpha.19 • Public • Published

babel-plugin-transform-typescript

Transform TypeScript into ES.next.

Does not type-check its input. For that, you will need to install and set up TypeScript.

Does not support namespaces or const enums because those require type information to transpile. Also does not support export = and import =, because those cannot be transpiled to ES.next.

Example

In

const x: number = 0;

Out

const x = 0;

Installation

npm install --save-dev babel-plugin-transform-typescript

Usage

Via .babelrc (Recommended)

.babelrc

{
  "plugins": ["transform-typescript"]
}

Via CLI

babel --plugins transform-typescript script.js

Via Node API

require("babel-core").transform("code", {
  plugins: ["transform-typescript"]
});

Package Sidebar

Install

npm i babel-plugin-transform-typescript

Weekly Downloads

6,564

Version

7.0.0-alpha.19

License

MIT

Last publish

Collaborators

  • hzoo