babel-plugin-transform-es2015-block-scoped-functions

6.22.0 • Public • Published

babel-plugin-transform-es2015-block-scoped-functions

Babel plugin to ensure function declarations at the block level are block scoped.

Installation

npm install --save-dev babel-plugin-transform-es2015-block-scoped-functions

Usage

Via .babelrc (Recommended)

.babelrc

{
  "plugins": ["transform-es2015-block-scoped-functions"]
}

Via CLI

babel --plugins transform-es2015-block-scoped-functions script.js

Via Node API

require("babel-core").transform("code", {
  plugins: ["transform-es2015-block-scoped-functions"]
});

Keywords

install

npm i babel-plugin-transform-es2015-block-scoped-functions

Downloadsweekly downloads

2,718,422

version

6.22.0

license

MIT

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
Report a vulnerability