babel-plugin-default-identifier

0.0.3 • Public • Published

babel-plugin-default-identifier

A Babel plugin to wrap the "default" identifier with apostrophes

This plugin is useful for legacy browsers or tools that treat "default" identifier as a keyword

Example

Input src/simple/actual.js

var x = {
  default: 0
};

Output dist/simple/actual.js

'use strict';
 
var x = {
  'default': 0
};

Getting started

Installation

$ npm install babel-plugin-default-identifier

Usage

Via .babelrc (Recommended)

{
  "plugins": ["default-identifier"]
}

Running tests

Run mocha tests with npm test

License

MIT

Package Sidebar

Install

npm i babel-plugin-default-identifier

Weekly Downloads

159

Version

0.0.3

License

MIT

Last publish

Collaborators

  • igor-dv