Wondering what’s next for npm?Check out our public roadmap! »

    babel-plugin-date-fns

    2.0.0 • Public • Published

    babel-plugin-date-fns

    ⚠️ The current version (2.x) supports date-fns v2. If you are using v1, please use 1.x.

    Install

    $ npm i --save date-fns
    $ npm i --save-dev babel-plugin-date-fns

    Example

    Transforms

    import { differenceInYears, format, formatDistance } from "date-fns";

    roughly to

     
    import differenceInYears from 'date-fns/differenceInYears';
    import format from "date-fns/format";
    import formatDistance from "date-fns/formatDistance";

    Usage

    .babelrc

    {
      "plugins": ["date-fns"],
      "presets": ["@babel/preset-env"]
    }

    Webpack

    module: {
      rules: [
        {
          test: /\.m?js$/,
          exclude: /(node_modules|bower_components)/,
          use: {
            loader: 'babel-loader',
            options: {
              presets: ['@babel/preset-env'],
              plugins: ['date-fns']
            }
          }
        }
      ]
    }

    Thanks

    Heavily inspired by babel-plugin-lodash and babel-plugin-recharts.

    Install

    npm i babel-plugin-date-fns

    DownloadsWeekly Downloads

    26,245

    Version

    2.0.0

    License

    MIT

    Unpacked Size

    4.21 kB

    Total Files

    4

    Last publish

    Collaborators

    • avatar