Nominal Package Missing

    async-require-context
    TypeScript icon, indicating that this package has built-in type declarations

    1.8.15 • Public • Published

    async-require-context

    Checks

    • Build
    • Code Style Analysis
    • Test CI

    A rewritten version of @wilsonlewis' require-context package that utilizes modern technologies.

    This module is not a drop in replacement for require-context.

    Getting started

    npm install --save async-require-context
    import asyncRequireContext from "async-require-context";

    Arguments

    asyncRequireContext(path, recursive, pattern);
    // In TypeScript, you can specify the type that each module is expected to be.
    // asyncRequireContext<Type>(path, recursive, pattern);
    Name Type Default Description
    path String none (required) Specifies the path to look for modules in.
    recursive Boolean true If true, will recurse through subdirectorys in path.
    pattern RegExp /\.js$/ Specifies a filter that files must match.

    Returns

    asyncRequireContext will always return Promise<Context[]>, if your using type annotations, it will be Promise<Context<Type>[]>

    The Context structure is:

    {
    	name: string, // Name of the module.
    	path: string, // Full path of the module.
    	module: require(path) // The module as if it was required with `require`. This may be any shape depending on if you use type annotations.
    }

    Install

    npm i async-require-context

    DownloadsWeekly Downloads

    915

    Version

    1.8.15

    License

    ISC

    Unpacked Size

    10.4 kB

    Total Files

    12

    Last publish

    Collaborators

    • jmer05