assert-polyfill

0.0.0 • Public • Published

Assert polyfill

Installation

npm install assert-polyfill --save

Why?

NodeJS v0 deepStrictEqual/notDeepStrictEqual is unavailable.

var assert = require('power-assert');
assert.deepStrictEqual(['foo'], ['foo'])
// TypeError: undefined is not a function
 
assert.notDeepStrictEqual(['foo'], ['bar'])
// TypeError: undefined is not a function

if above function is undefined, assert-polyfill defines the polyfill functions.

require('assert-polyfill');
var assert = require('power-assert');
assert.deepStrictEqual(['foo'], ['foo']) // pass
assert.notDeepStrictEqual(['foo'], ['bar']) // pass

even if --require in mocha, it is similar.

mocha --require assert-polyfill

Development

Requirement global

  • NodeJS v0.12.13
  • Npm v2.15.0
git clone https://github.com/59naga/assert-polyfill
cd assert-polyfill
npm install
 
npm test

License

MIT

Package Sidebar

Install

npm i assert-polyfill

Weekly Downloads

138

Version

0.0.0

License

MIT

Last publish

Collaborators

  • 59naga