Share your code. npm Orgs help your team discover, share, and reuse code. Create a free org »

    angular-ui-selectpublic

    This package has been deprecated

    Author message:

    This is an unmaintained version. Please use the module 'ui-select'

    AngularJS ui-select Build Status

    Gitter

    AngularJS-native version of Select2 and Selectize.

    Features

    • Search, Select, and Multi-select
    • Themes: Bootstrap, Select2 and Selectize
    • Keyboard support
    • jQuery not required (except for old browsers)
    • Small code base: 4.57KB min/gzipped vs 20KB for select2

    For the roadmap, check issue #3 and the Wiki page.

    Development

    Prepare your environment

    • Install Node.js and NPM (should come with)
    • Install global dev dependencies: npm install -g bower gulp
    • Install local dev dependencies: npm install && bower install in repository directory

    Development Commands

    • gulp to jshint, build and test
    • gulp build to jshint and build
    • gulp test for one-time test with karma (also build and jshint)
    • gulp watch to watch src files to jshin, build and test when changed

    Contributing

    When issuing a pull request, please exclude changes from the "dist" folder to avoid merge conflicts.

    Keywords

    none

    install

    npm i angular-ui-select

    Downloadslast 7 days

    2,584

    version

    0.12.100

    license

    MIT

    repository

    github.com

    last publish

    collaborators

    • avatar
    • avatar