node package manager
We need your input. Help make JavaScript better: Take the 2017 JavaScript Ecosystem survey »

airbnb-js-shims

airbnb-js-shims Version Badge

JS language shims used by Airbnb.

Just require/import airbnb-js-shims, and the environment will be shimmed.

import 'airbnb-js-shims';

Included shims

Targeting versions

If you do not need to support older browsers, you can pick a subset of ES versions to target. For example, if you don't support pre-ES5 browsers, you can start your shims with ES2015 by requiring/importing the specific target file. This will shim the environment for that version and upward.

import 'airbnb-js-shims/target/es2015';

Included targets

  • airbnb-js-shims/target/es5 (default)
  • airbnb-js-shims/target/es2015
  • airbnb-js-shims/target/es2016
  • airbnb-js-shims/target/es2017
  • airbnb-js-shims/target/es2018