agnostic-svelte
TypeScript icon, indicating that this package has built-in type declarations

1.1.27 • Public • Published

AgnosticUI Svelte

This is the Svelte version of AgnosticUI.

As earlier versions of Svelte caused binding issues in several of AgnosticUI's components, we've upgraded the library using the latest Svelte-Kit and requires "svelte": "^3.46.0" and later.

AgnosticUI Docs

Npm install

  • npm install agnostic-svelte or yarn add agnostic-svelte
  • In your project's public/index.html ensure sure you've included the bundle.css
  • In your src/App.svelte import agnostic-svelte/css/common.min.css before any agnostic-svelte components; it will look something like:
<script>
	import 'agnostic-svelte/css/common.min.css';
	import { Button } from 'agnostic-svelte';
</script>
<!-- In your html section you can now use the agnostic-svelte component -->
<Button>Go</Button>

A complete kitchen sink example is located in ./examples/src/App.svelte

Package Sidebar

Install

npm i agnostic-svelte

Weekly Downloads

395

Version

1.1.27

License

Apache-2.0

Unpacked Size

401 kB

Total Files

193

Last publish

Collaborators

  • rlevin