@yoozsoft/yoozsoft-ng
TypeScript icon, indicating that this package has built-in type declarations

1.3.1-alpha.0 • Public • Published

Yoozsoft Ng

Angular widgets built up using Bootstrap 5 CSS and NG Bootstrap 15 widgets with APIs designed for the Angular ecosystem, that are in standalone style. We are using TypeScript and targeting the Ng Bootstrap 15 widgets and Bootstrap 5 CSS framework. As with Bootstrap 5 and Angular 2, this library is a work in progress.

The dependencies are Angular, Ng Bootstrap 15 widgets, Bootstrap 5 CSS, Popper.

Table of Contents

Demo

Visit the Yoozsoft Website for general information, demos and documentation.

Dependencies

The only dependencies are Angular, Ng Bootstrap 15 widgets, Bootstrap 5 CSS, and Popper. The supported versions are:

yoozsoft-ng ng-bootstrap Angular Bootstrap CSS Popper
1.x.x-alpha.x 15.0.1 16.1.0 5.3.0 2.11.8

Installation

Add bootstrap, @popperjs/core, @ng-bootstrap/ng-bootstrap dependencies from npm.

Run npm i @yoozsoft/yoozsoft-ng to install the package. Import any standalone component like YsNavbarComponent in your modules, or directly import the components and directives that you use, which are standalone.

Package Sidebar

Install

npm i @yoozsoft/yoozsoft-ng

Weekly Downloads

58

Version

1.3.1-alpha.0

License

MIT

Unpacked Size

681 kB

Total Files

162

Last publish

Collaborators

  • yoozsoft