@vuepress/markdown

1.9.10 • Public • Published

@vuepress/markdown

markdown library for VuePress

Public API

PLUGINS

A map constant containing the names of all built-in markdown-it plugins.

isRequiredPlugin(pluginName: string)

  • Usage:
const { isRequiredPlugin } = require('@vuepress/markdown')
console.log(isRequiredPlugin(PLUGINS.COMPONENT)) // true
console.log(isRequiredPlugin(PLUGINS.HIGHLIGHT_LINES)) // false

removePlugin(config: chainMarkdown, pluginName: string)

Remove the specified built-in markdown-it plugin in VuePress.

It's needed to use with VuePress’s Plugin API > chainMarkdown.

  • Usage:
// Your VuePress Plugin or site config.
const { removePlugin } = require('@vuepress/markdown')
module.exports = {
  chainMarkdown (config) {
    removePlugin(config, PLUGINS.HIGHLIGHT_LINES)
  }
}

Note that PLUGINS.COMPONENT and PLUGINS.ANCHOR are required in VuePress, It is forbidden to delete them!

removeAllBuiltInPlugins(config: chainMarkdown)

Remove all built-in but not 100% necessary markdown-it plugins in VuePress.

  • Usage:
// Your VuePress Plugin or site config.
module.exports = {
  chainMarkdown (config) {
    require('@vuepress/markdown').removeAllBuiltInPlugins(config)
  }
}

Package Sidebar

Install

npm i @vuepress/markdown

Weekly Downloads

59,642

Version

1.9.10

License

MIT

Unpacked Size

22.6 kB

Total Files

13

Last publish

Collaborators

  • ulivz
  • meteorlxy