@twilio/flex-ui
TypeScript icon, indicating that this package has built-in type declarations

2.8.1 • Public • Published

Twilio Flex UI

A library of composable components for creating an extendable and customizable user interface for Twilio Flex cloud-based contact center application platform Instantiating and consuming @twilio/flex-ui.

This library can only be consumed together with Twilio Flex. Visit http://twilio.com/flex to find out more.

Known issues

  • flex-ui@2.8.0 contains an issue which prevents dependencies from installing correctly. Please use flex-ui@^2.8.1 onwards, where this issue has been resolved.
  • In flex-ui@^2.7.0 and later, if your custom application uses react-scripts@^5.0.0, you must apply a workaround due to a react-scripts issue. For details, see the release notes: https://www.twilio.com/docs/flex/release-notes/flex-ui-release-notes-for-v2xx#v-270.

Readme

Keywords

none

Package Sidebar

Install

npm i @twilio/flex-ui

Weekly Downloads

5,116

Version

2.8.1

License

Apache-2.0

Unpacked Size

34.3 MB

Total Files

1163

Last publish

Collaborators

  • twilio-flex-ui-ci