@storybook/builder-webpack4
TypeScript icon, indicating that this package has built-in type declarations

6.5.16 • Public • Published

Builder-Webpack4

Builder implemented with webpack4 and webpack4-compatible loaders/plugins/config, used by @storybook/core-server to build the preview iframe.

builder-webpack4 is the default, so no configuration is necessary to use it. However, if you wan to explicitly configure your Storybook to run builder-webpack4, install it as a dev dependency and then update your .storybook/main.js configuration.

module.exports = {
  core: {
    builder: 'webpack4',
  },
};

Readme

Keywords

Package Sidebar

Install

npm i @storybook/builder-webpack4

Weekly Downloads

1,376,797

Version

6.5.16

License

MIT

Unpacked Size

104 kB

Total Files

46

Last publish

Collaborators

  • domyen
  • kasperpeulen
  • valentinpalkovic
  • jreinhold
  • kylegach
  • ndelangen
  • shilman
  • tmeasday
  • ghengeveld
  • winkervsbecks
  • yannbf