@snyk/sweater-comb
TypeScript icon, indicating that this package has built-in type declarations

2.3.29 • Public • Published

@snyk/sweater-comb

“Sweats the small stuff, so you don’t have to. OpenAPI linting rules for Snyk APIs.”

What is Sweater Comb?

At Snyk, we’re starting an API Program whose goal it is to create a beautiful garden of repeatable & concise APIs that empower Snyk customers, partners, and Snyk’ers alike to easily and quickly build new experiences and products.

Such an API needs some guardrails to stay cohesive, consistent and “unsurprising” to its consumers, as the platform scales in the number of concepts it provides and the number of teams delivering them.

Sweater Comb is a tool which provides some of those guardrails with automation, initially by applying custom Optic CI rules to Snyk's OpenAPI specifications.

Read more about the project in Sweater Comb documentation.

Installation and Usage

npm install @snyk/sweater-comb --save-dev

Contributing

If you are contributing to Sweater Comb, read the contributing guidelines

License

Licensed under the Apache 2.0 License

Copyright (c) 2021-present, Snyk Ltd.

Readme

Keywords

none

Package Sidebar

Install

npm i @snyk/sweater-comb

Weekly Downloads

4,230

Version

2.3.29

License

none

Unpacked Size

777 kB

Total Files

163

Last publish

Collaborators

  • snyk-admin
  • snyk-user