Nuns Practicing Misanthropy

    @sindresorhus/tsconfig

    3.0.1 • Public • Published

    tsconfig

    Shared TypeScript config for my projects

    Install

    npm install --save-dev @sindresorhus/tsconfig

    This config requires TypeScript 4.7 or later.

    Usage

    tsconfig.json

    {
    	"extends": "@sindresorhus/tsconfig",
    	"compilerOptions": {
    		"outDir": "dist"
    	}
    }

    When you are targeting a higher version of Node.js, check the relevant ECMAScript version and add it as target:

    {
    	"extends": "@sindresorhus/tsconfig",
    	"compilerOptions": {
    		"outDir": "dist",
    		"target": "ES2021"
    	}
    }

    Install

    npm i @sindresorhus/tsconfig

    DownloadsWeekly Downloads

    3,394

    Version

    3.0.1

    License

    MIT

    Unpacked Size

    3.29 kB

    Total Files

    4

    Last publish

    Collaborators

    • sindresorhus