@rocket.chat/ui-kit
    TypeScript icon, indicating that this package has built-in type declarations

    0.30.1 • Public • Published

    Rocket.Chat

    @rocket.chat/ui-kit

    Interactive UI elements for Rocket.Chat Apps


    npm@latest npm@next npm downloads License: MIT

    deps peer deps dev deps npm bundle size

    Install

    Add @rocket.chat/ui-kit as a dependency:

    npm i @rocket.chat/ui-kit
    
    # or, if you are using yarn:
    
    yarn add @rocket.chat/ui-kit

    Contributing

    Contributions, issues, and feature requests are welcome!
    Feel free to check the issues.

    Building

    As this package dependends on others in this monorepo, before anything run the following at the root directory:

    yarn build

    Linting

    To ensure the source is matching our coding style, we perform linting. Before commiting, check if your code fits our style by running:

    yarn lint

    Some linter warnings and errors can be automatically fixed:

    yarn lint-fix

    Running tests

    Whenever possible, add tests to describe exactly what your code do. You can run them by yourself:

    yarn test

    Keywords

    none

    Install

    npm i @rocket.chat/ui-kit

    DownloadsWeekly Downloads

    4,824

    Version

    0.30.1

    License

    MIT

    Unpacked Size

    281 kB

    Total Files

    579

    Last publish

    Collaborators

    • rodrigok
    • sing.li
    • graywolf336
    • diegosampaio
    • gazzo
    • dgubert
    • tassoevan