npm

Check out our latest tech talk, "JavaScript Supply Chain Security" presented by VP of Security, Adam Baldwin.Watch it here »

@pubcore/generator-rest

1.1.0 • Public • Published

Build Status

Commandline tool create a pubcore component for a RESTful api scaffolding

Prerequisites

  • latest version of nodejs
  • latest version of npm
  • optional (Install will succeed without this, too):
    @pubcore/node-composition installed and context_path is added in config.json

It will create/setup minimum package structure to support

  • eslint
  • testing via express and mocha

Install it global

npm install -g yo @pubcore/generator-rest

How to use

  1. create a directory
    (convention: lower case, dash-separated)

     mkdir my-api
    
  2. and change into it

     cd my-api
    
  3. execute

     yo @pubcore/rest
    

install

npm i @pubcore/generator-rest

Downloadsweekly downloads

13

version

1.1.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
Report a vulnerability