No Password Management

    @patternfly/react-code-editor
    TypeScript icon, indicating that this package has built-in type declarations

    4.65.1 • Public • Published

    @patternfly/react-code-editor

    This package provides a PatternFly wrapper for the Monaco code editor

    Prerequisite

    Node Environment

    This project currently supports Node Active LTS releases. Please stay current with Node Active LTS when developing patternfly-react.

    For example, to develop with Node 8, use the following:

    nvm install 8
    nvm use 8
    

    This project also requires a Yarn version of >=1.6.0. The latest version can be installed here.

    Installing

    yarn add @patternfly/react-code-editor
    

    or

    npm install @patternfly/react-code-editor --save
    

    Usage

    Pre-requisites

    It's strongly advised to use the PatternFly Base CSS in your whole project, or some components may diverge in appearance:

    import '@patternfly/react-core/dist/styles/base.css';
    import { CodeEditor } from '@patternfly/react-code-editor';

    Install peer deps

    "monaco-editor": "^0.21.3",
    "monaco-editor-webpack-plugin": "^2.1.0",
    "react": "^16.8.0 || ^17.0.0",
    "react-dom": "^16.8.0 || ^17.0.0",
    "react-monaco-editor": "^0.41.2"

    To properly install the library monaco-editor-webpack-plugin be sure to follow the plugin instructions

    Install

    npm i @patternfly/react-code-editor

    DownloadsWeekly Downloads

    2,078

    Version

    4.65.1

    License

    MIT

    Unpacked Size

    280 kB

    Total Files

    66

    Last publish

    Collaborators

    • ctrowbri
    • dgutride
    • dlabrecq
    • patternfly-build
    • jeff-phillips-18
    • mturley
    • mwcz
    • kylebuch8
    • realredallen
    • ktotten
    • evwilkin
    • schulj12
    • castastrophe
    • nicolethoen
    • heymp
    • zhawkins