npm

npm’s 2019 JavaScript ecosystem survey analysis is now available! Get your copy here »

@opencensus/propagation-stackdriver

0.0.11 • Public • Published

OpenCensus Stackdriver Propagation for Node.js

Gitter chat

OpenCensus Stackdriver Propagation allow other services to create spans with the right context.

The library is in alpha stage and the API is subject to change.

Installation

Install OpenCensus Stackdriver Propagation with:

npm install @opencensus/propagation-stackdriver

Usage

To propagate span context arround services with Stackdriver Propagation, pass an instance of Stackdriver Propagation to your tracing instance. For Javascript:

const tracing = require('@opencensus/nodejs');
const propagation = require('@opencensus/propagation-stackdriver');
 
const sd = propagation.v1;
 
tracing.start({propagation: sd});

Similarly for Typescript:

import * as tracing from '@opencensus/nodejs';
import * as propagation from '@opencensus/propagation-stackdriver';
 
const sd = propagation.v1;
 
tracing.start({propagation: sd});

Useful links

install

npm i @opencensus/propagation-stackdriver

Downloadsweekly downloads

76,728

version

0.0.11

license

Apache-2.0

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
Report a vulnerability