@mmcodemark/eslint-config-alt

0.32.0 • Public • Published

Rocket.Chat

@mmcodemark/eslint-config-alt

ESLint configuration for Rocket.Chat repositories


npm@latest npm@next npm downloads License: MIT

deps npm bundle size

Install

Firstly, install the peer dependencies (prerequisites):

npm i -D @babel/eslint-parser eslint prettier

# or, if you are using yarn:

yarn add -D @babel/eslint-parser eslint prettier

Add @mmcodemark/eslint-config-alt as a dependency:

npm i -D @mmcodemark/eslint-config-alt

# or, if you are using yarn:

yarn add -D @mmcodemark/eslint-config-alt

Contributing

Contributions, issues, and feature requests are welcome!
Feel free to check the issues.

Linting

To ensure the source is matching our coding style, we perform linting. Before commiting, check if your code fits our style by running:

yarn lint

Some linter warnings and errors can be automatically fixed:

yarn lint-and-fix

Readme

Keywords

none

Package Sidebar

Install

npm i @mmcodemark/eslint-config-alt

Weekly Downloads

0

Version

0.32.0

License

MIT

Unpacked Size

64.2 kB

Total Files

14

Last publish

Collaborators

  • valeriy.malyshev
  • denis.akimov
  • mmcodemark-user