Neighbor's Preppy Maltese

    @mediamonks/eslint-config-vue

    2.0.0 • Public • Published

    @mediamonks/eslint-config-vue npm version

    This package provides a Vue TypeScript eslint configuration as an extensible shared config, based on the MediaMonks Coding Standards.

    Installation

    The configuration has a number of peer dependencies that must be installed.

    npm i --dev @mediamonks/eslint-config-vue

    Note for yarn users: yarn does not install peer dependencies by default, this can be supplemented with install-peerdeps. Because this config depends on @mediamonks/eslint-config-base, you will first have to install its peer dependencies.

    npx install-peerdeps --dev --only-peers @mediamonks/eslint-config-base
    npx install-peerdeps --dev @mediamonks/eslint-config-vue

    Usage

    Now you can add @mediamonks/eslint-config-vue to your .eslintrc. Adding parserOptions.project is only required if your project is using TypeScript.

    {
      "extends": "@mediamonks/eslint-config-vue",
      "parserOptions": {
        "project": "./tsconfig.json" // can also be an array, if multiple `tsconfig.json` are present
      }
    }

    Formatting & Prettier

    This eslint configuration purposely had its formatting rules disabled. We encourage to use prettier for formatting using the @mediamonks/prettier-config.

    Install

    npm i @mediamonks/eslint-config-vue

    DownloadsWeekly Downloads

    35

    Version

    2.0.0

    License

    MIT

    Unpacked Size

    3.06 kB

    Total Files

    3

    Last publish

    Collaborators

    • will-newton
    • jessel
    • twan.braas
    • leroykorterink
    • mientjan
    • devmonk
    • thanarie
    • thi.js
    • psimk
    • nathanuphoff
    • larsvanbraam