@m6web/eslint-plugin-vue

    3.5.0 • Public • Published

    @m6web/eslint-plugin-vue

    The purpose of this package is simple, simplify the configuration of eslint and prettier in our projects.

    It provides:

    With that come some little changes from the default config of eslint-config-airbnb and prettier that you can find in index.js file and [here].

    Setup

    npm install --dev @m6web/eslint-plugin-vue babel-eslint

    or

    yarn add --dev @m6web/eslint-plugin-vue babel-eslint

    Then you need to add the plugin in the .eslintrc file of your project. For that create a .eslintrc and add the following lines:

    {
      "extends": "plugin:@m6web/eslint-plugin-vue/default",
    }

    And that's all.

    If you want to customize some rules, follow the eslint documentation.

    Jest / Jasmine Support

    If you want, you can add the jest support with the following lines:

    {
      "env": {
        "browser": true,
        "jasmine": true
      }
    }

    Usage

    Lint your code:

    yarn eslint src/

    Rewrite your code, the right way 😈:

    yarn prettier-eslint -- --write 'src/**/*.js'

    here

    Keywords

    none

    Install

    npm i @m6web/eslint-plugin-vue

    DownloadsWeekly Downloads

    31

    Version

    3.5.0

    License

    MIT

    Unpacked Size

    3.28 kB

    Total Files

    3

    Last publish

    Collaborators

    • clement-berard
    • fdubost
    • flepretre
    • oltodo
    • slashgear
    • the-smaug