@konnec/vue-eloquent
TypeScript icon, indicating that this package has built-in type declarations

1.3.1 • Public • Published

Vue Eloquent

An interface for Vue 3 and Laravel Eloquent models through API requests.

Monthly downloads Vue.js 3 compatible License TypeScript Supported Maintenance Status Code Coverage

Installation

There are two packages available that can be used independently, but work better together.

Vue 3 Package

yarn add @konnec/vue-eloquent

Vue Requirements

  1. Vue 3

Laravel Package

composer require konnec/vue-eloquent-api

Laravel Requirements

  1. Laravel 10
  2. PHP ^8.1

Documentation

Visit Vue Eloquent Docs

Maintenance Status

Active: We're actively working on this project, and we expect to continue for work for the foreseeable future. Bug reports, feature requests and pull requests are welcome.

Contribution

Any ideas are welcome. Feel free to submit any issues or pull requests.

License

The MIT License (MIT). Please see License File for more information.

Package Sidebar

Install

npm i @konnec/vue-eloquent

Weekly Downloads

443

Version

1.3.1

License

MIT

Unpacked Size

151 kB

Total Files

109

Last publish

Collaborators

  • cimd