@hmcts/div-idam-test-harness

    1.9.0 • Public • Published

    Divorce IDAM Express Test Harness

    A test harness for the IDAM-Express-Middleware

    Requirements

    • Node >=8.0
    • yarn

    Installation

    # Install the latest version
    yarn add "@hmcts/div-idam-test-harness"
    
    # Install a specific version
    yarn add "@hmcts/div-idam-test-harness@1.2.1"

    Usage

    Require this module in your tests and call idamExpressTestHarness.stub() before the app is initialised.

    Remember to call .restore() after every test.

    Keywords

    none

    Install

    npm i @hmcts/div-idam-test-harness

    DownloadsWeekly Downloads

    161

    Version

    1.9.0

    License

    MIT

    Unpacked Size

    23.5 kB

    Total Files

    18

    Last publish

    Collaborators

    • bendiggle
    • ellie-harrison
    • adrianc
    • hemantt
    • adamsilver
    • trevorsaint
    • timja-hmcts
    • dharmendrak
    • robertparkinson
    • pragnesh
    • damdun
    • p.jar
    • sabah.irfan
    • jenkins-reform-hmcts
    • andrewwa-kainos
    • timja