@gusmano/ext-angular-classic
    TypeScript icon, indicating that this package has built-in type declarations

    0.0.33 • Public • Published

    ext-angular-classic

    ExtAngular - Utilize Sencha Ext JS 6.5.3 classic toolkit components in an Angular application

    PreRequisites:

    Instructions on how to get the sample running

    (run in terminal/command window)

    • ng new Classic --minimal

    • cd Classic

    • npm i --save @gusmano/ext-angular-classic

    • npm i --save @gusmano/ext-angular-demos

    • npm i --save bootstrap

    • cp -a node_modules/@gusmano/ext-angular-demos/simple/src/. ./src/

    • copy the Ext JS 6.5.3 framework to a folder named src/ext-6.5.3

      • see above PreRequisites to get Ext JS 6.5.3 framework
      • also get the Ext Premium Addons and copy them to the packages folder of the framework
      • only need the build and packages folders
    • replace these sections in .angular-cli.json (or angular.json in newest version of Angular CLI)

        "assets": [
        	"ext-6.5.3",
        	"assets",
        	"favicon.ico"
        ],
      
        "styles": [
        	"../node_modules/bootstrap/dist/css/bootstrap.css",
        	"styles.css"
        ],
      
    • ng serve

    Running Example:

    http://se.sencha.com/ExtAngularExample

    Install

    npm i @gusmano/ext-angular-classic

    DownloadsWeekly Downloads

    10

    Version

    0.0.33

    License

    MIT

    Unpacked Size

    2.28 MB

    Total Files

    417

    Last publish

    Collaborators

    • mgusmano