@electron-boilerplate/sentry
    TypeScript icon, indicating that this package has built-in type declarations

    1.1.1 • Public • Published

    @electron-boilerplate/sentry

    This library is primarily designed for use with electron-boilerplate and starts elctron-sentry in both the main and renderer processes.

    Usage

    npm install electron-boilerplate @electron-boilerplate/sentry

    In your main process simply:

    const { ElectronBoilerplate } = require('electron-boilerplate');
    const { electronSentry } = require('@electron-boilerplate/sentry');
    
    ElectronBoilerplate
      // This should come before 'standardConfiguration' or any other 'use' call
      // This will ensure that the crash reporters are started first
      .use(electronSentry(true))
      .standardConfiguration()
      .run();

    electronSentry parameters

    Parameter Type Description Default
    ignoreUserSetting boolean If this is true it will not check that ElectronSentry.isEnabled() false
    dsnOrOptions string or ElectronSentryOptions Sentry non-public DSN string or options object. See electron-sentry for the full list of options and defaults. If nothing is supplied here, the sentry node from the root of the package.json is used undefined

    Keywords

    none

    Install

    npm i @electron-boilerplate/sentry

    DownloadsWeekly Downloads

    1

    Version

    1.1.1

    License

    MIT

    Last publish

    Collaborators

    • timfish