This package has been deprecated

Author message:

AWS CDK v1 has reached End-of-Support on 2023-06-01. This package is no longer being updated, and users should migrate to AWS CDK v2. For more information on how to migrate, see https://docs.aws.amazon.com/cdk/v2/guide/migrating-v2.html

@aws-cdk/lambda-layer-awscli
TypeScript icon, indicating that this package has built-in type declarations

1.204.0 • Public • Published

AWS Lambda Layer with AWS CLI


End-of-Support

AWS CDK v1 has reached End-of-Support on 2023-06-01. This package is no longer being updated, and users should migrate to AWS CDK v2.

For more information on how to migrate, see the Migrating to AWS CDK v2 guide.


This module exports a single class called AwsCliLayer which is a lambda.Layer that bundles the AWS CLI.

Any Lambda Function that uses this layer must use a Python 3.x runtime.

Usage:

// AwsCliLayer bundles the AWS CLI in a lambda layer
import { AwsCliLayer } from '@aws-cdk/lambda-layer-awscli';

declare const fn: lambda.Function;
fn.addLayers(new AwsCliLayer(this, 'AwsCliLayer'));

The CLI will be installed under /opt/awscli/aws.

Package Sidebar

Install

npm i @aws-cdk/lambda-layer-awscli

Weekly Downloads

8,345

Version

1.204.0

License

Apache-2.0

Unpacked Size

15.9 MB

Total Files

18

Last publish

Collaborators

  • amzn-oss
  • aws-cdk-team