@archway-kit/tailwind-plugin
TypeScript icon, indicating that this package has built-in type declarations

0.5.12 • Public • Published

@archway-kit/tailwind-plugin

A Tailwind CSS plugin that provides a set of classes and styles for the archway-kit components.

Installation

Install the plugin from npm:

npm install -D @archway-kit/tailwind-plugin

Then add the plugin to your tailwind.config.js file:

// tailwind.config.js
module.exports = {
  // ...
  plugins: [
    // ...
    require('@archway-kit/tailwind-plugin')({
      ...
    }),
  ],
}

It will add core styles and tailwind components, as well as css palette variables.

Configuration

To customize how the plugin handles themes, you need to provide configuration object:

// tailwind.config.js
module.exports = {
  // ...
  plugins: [
    // ...
    require('@archway-kit/tailwind-plugin')({
      lightThemeClass: 'my-custom-light-class',
      darkThemeClass: 'my-custom-dark-class',
      ignorePreferences: false,
      fallbackDark: false,
    }),
  ],
}

More

For full documentation about the Archway Network and its ecosystem, visit Archway Docs.

Community

For help, discussion about best practices, or any other conversation that would benefit from being searchable:

Discuss Archway Kit on GitHub

Package Sidebar

Install

npm i @archway-kit/tailwind-plugin

Weekly Downloads

384

Version

0.5.12

License

Apache-2.0

Unpacked Size

155 kB

Total Files

98

Last publish

Collaborators

  • archway-bot