@advanced-rest-client/pouchdb-mapreduce-no-ddocs

    3.0.3 • Public • Published

    DEPRECATION NOTICE

    This project is essentially a hack designed to get pouchdb-quick-search to work correctly without creating DDocs. Probably the best path forward is to deprecate this project and have pouchdb-quick-search use pouchdb-abstract-mapreduce, which is what's used by pouchdb-mapreduce and pouchdb-find under the hood. Removing DDocs is a convenience for users but makes it hard to keep this module up-to-date with mapreduce changes.

    pouchdb-mapreduce-utils semver non-compliant

    PouchDB utilities used by pouchdb-mapreduce.

    Usage

    npm install --save-exact pouchdb-mapreduce-utils

    For full API documentation and guides on PouchDB, see PouchDB.com. For details on PouchDB sub-packages, see the Custom Builds documentation.

    Warning: semver-free zone!

    This package is conceptually an internal API used by PouchDB or its plugins. It does not follow semantic versioning (semver), and rather its version is pegged to PouchDB's. Use exact versions when installing, e.g. with --save-exact.

    Source

    PouchDB and its sub-packages are distributed as a monorepo.

    For a full list of packages, see the GitHub source.

    Keywords

    none

    Install

    npm i @advanced-rest-client/pouchdb-mapreduce-no-ddocs

    DownloadsWeekly Downloads

    500

    Version

    3.0.3

    License

    Apache-2.0

    Unpacked Size

    113 kB

    Total Files

    9

    Last publish

    Collaborators

    • carowright
    • jarrodek
    • twoplustwoone
    • lbauret