@1password/pulumi-onepassword
TypeScript icon, indicating that this package has built-in type declarations

1.0.2 • Public • Published

1Password Pulumi provider

Use the 1Password Pulumi provider to access and manage items in your 1Password vaults.

Installing

This package is available for several languages/platforms:

Node.js (JavaScript/TypeScript)

To use from JavaScript or TypeScript in Node.js, install using either npm:

npm install @1password/pulumi-onepassword

or yarn:

yarn add @1password/pulumi-onepassword

Python

To use from Python, install using pip:

pip install pulumi-onepassword

Go

To use from Go, use go get to grab the latest version of the library:

go get github.com/1Password/pulumi-onepassword/sdk/go/...

Configuration

The following configuration points are available for the 1Password provider:

  • pulumi-onepassword:url (environment: OP_CONNECT_HOST) - the URL where your 1Password Connect API can be found
  • pulumi-onepassword:token (environment: OP_CONNECT_TOKEN) - the token for your Connect API.
  • pulumi-onepassword:service_account_token (environment: OP_SERVICE_ACCOUNT_TOKEN) - The 1Password service account token to use with 1Password CLI.
  • pulumi-onepassword:account (environment: OP_ACCOUNT) - A valid account's sign-in address or ID to use with 1Password CLI and biometric unlock.
  • pulumi-onepassword:op_cli_path (environment: OP_CLI_PATH) - The path to the 1Password CLI binary.

Reference

For detailed reference documentation, please visit the Pulumi registry.

Package Sidebar

Install

npm i @1password/pulumi-onepassword

Weekly Downloads

13

Version

1.0.2

License

Apache-2.0

Unpacked Size

74.4 kB

Total Files

37

Last publish

Collaborators

  • onepassword