@0x/sol-cov
TypeScript icon, indicating that this package has built-in type declarations

2.1.17 • Public • Published

@0x/sol-cov

A Solidity code coverage tool.

Read the Documentation.

Installation

yarn add @0x/sol-cov

Import

import { CoverageSubprovider } from '@0x/sol-cov';

or

var CoverageSubprovider = require('@0x/sol-cov').CoverageSubprovider;

Contributing

We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.

Please read our contribution guidelines before getting started.

Install dependencies

If you don't have yarn workspaces enabled (Yarn < v1.0) - enable them:

yarn config set workspaces-experimental true

Then install dependencies

yarn install

Build

To build this package and all other monorepo packages that it depends on, run the following from the monorepo root directory:

PKG=@0x/sol-cov yarn build

Or continuously rebuild on change:

PKG=@0x/sol-cov yarn watch

Clean

yarn clean

Lint

yarn lint

Run Tests

yarn test

Readme

Keywords

none

Package Sidebar

Install

npm i @0x/sol-cov

Weekly Downloads

2

Version

2.1.17

License

Apache-2.0

Unpacked Size

304 kB

Total Files

138

Last publish

Collaborators

  • aeph4muh
  • rhinodavid
  • mwelche
  • savdont
  • kyuc
  • henryzhu
  • tobernguyen
  • dekz
  • amirbandeali
  • phil-ociraptor