Neoclassical Philosophic Musings
    Wondering what’s next for npm?Check out our public roadmap! »

    zen-observable-ts
    TypeScript icon, indicating that this package has built-in type declarations

    1.0.0 • Public • Published

    zen-observable-ts

    Thin wrapper around zen-observable and @types/zen-observable, to support ESM exports as well as CommonJS exports, with TypeScript types provided by @types/zen-observable.

    Usage

    After installing zen-observable-ts using a tool like npm or yarn, you can import the Observable class by name:

    import { Observable } from "zen-observable-ts";

    Note that this package does not currently have a default export, so the {} braces are mandatory.

    Previous versions

    This tiny wrapper package replaces an older version of zen-observable-ts that used to provide TypeScript types for zen-observable, before @types/zen-observable was introduced. This version of the package is not intended to be perfectly compatible with the older version, so we have bumped the major version of the package to reflect the difference.

    Future plans

    As explained in https://github.com/apollographql/apollo-client/pull/7615, the zen-observable-ts package exists to fill a gap in the functionality of the zen-observable package, so we will retire this package in favor of using zen-observable directly, when/if this PR is ever merged.

    Keywords

    none

    Install

    npm i zen-observable-ts

    DownloadsWeekly Downloads

    2,996,771

    Version

    1.0.0

    License

    MIT

    Unpacked Size

    6.33 kB

    Total Files

    9

    Last publish

    Collaborators

    • avatar
    • avatar