Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

wzrd-api-client

1.0.0 • Public • Published

wzrd-api-client

Make requests to browserify CDN wzrd.in.

Usage

bundle a module:

var bundle = require('wzrd-api-client/bundle')
 
bundle('bunny', function (err, res, body) {
  console.log(body)
})

bundle specific version:

var bundle = require('wzrd-api-client/bundle')
 
bundle('bunny', { version: '1.0.0' }, function (err, res, body) {
  console.log(body)
})

bundle multiple dependencies:

var multi = require('wzrd-api-client/multi')
 
var body = {
  options: { debug: true },
  dependencies: {
    bunny: 'latest',
    regl: 'latest',
    resl: 'latest'
  }
}
 
multi(body, function (err, res, body) {
  console.log(body.regl)
  console.log(body.resl)
  console.log(body.bunny)
})

create a standalone bundle:

var standalone = require('wzrd-api-client/standalone')
 
standalone('bunny', function (err, res, body) {
  console.log(body)
})

check the status of a module

var status = require('wzrd-api-client/status')
 
status('bunny', function (err, res, body) {
  console.log(body)
})

License

MIT

Install

npm i wzrd-api-client

DownloadsWeekly Downloads

4

Version

1.0.0

License

MIT

Last publish

Collaborators

  • avatar